summaryrefslogtreecommitdiff
path: root/clang/lib/Sema/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'clang/lib/Sema/CMakeLists.txt')
-rw-r--r--clang/lib/Sema/CMakeLists.txt58
1 files changed, 58 insertions, 0 deletions
diff --git a/clang/lib/Sema/CMakeLists.txt b/clang/lib/Sema/CMakeLists.txt
new file mode 100644
index 0000000..07734c7
--- /dev/null
+++ b/clang/lib/Sema/CMakeLists.txt
@@ -0,0 +1,58 @@
+set(LLVM_USED_LIBS
+ clangAST
+ clangAnalysis
+ clangBasic
+ clangEdit
+ clangLex
+ )
+
+add_clang_library(clangSema
+ AnalysisBasedWarnings.cpp
+ AttributeList.cpp
+ CodeCompleteConsumer.cpp
+ DeclSpec.cpp
+ DelayedDiagnostic.cpp
+ IdentifierResolver.cpp
+ JumpDiagnostics.cpp
+ Scope.cpp
+ Sema.cpp
+ SemaAccess.cpp
+ SemaAttr.cpp
+ SemaCXXScopeSpec.cpp
+ SemaCast.cpp
+ SemaChecking.cpp
+ SemaCodeComplete.cpp
+ SemaConsumer.cpp
+ SemaDecl.cpp
+ SemaDeclAttr.cpp
+ SemaDeclCXX.cpp
+ SemaDeclObjC.cpp
+ SemaExceptionSpec.cpp
+ SemaExpr.cpp
+ SemaExprCXX.cpp
+ SemaExprMember.cpp
+ SemaExprObjC.cpp
+ SemaFixItUtils.cpp
+ SemaInit.cpp
+ SemaLambda.cpp
+ SemaLookup.cpp
+ SemaObjCProperty.cpp
+ SemaOverload.cpp
+ SemaPseudoObject.cpp
+ SemaStmt.cpp
+ SemaStmtAttr.cpp
+ SemaTemplate.cpp
+ SemaTemplateDeduction.cpp
+ SemaTemplateInstantiate.cpp
+ SemaTemplateInstantiateDecl.cpp
+ SemaTemplateVariadic.cpp
+ SemaType.cpp
+ TargetAttributesSema.cpp
+ )
+
+add_dependencies(clangSema ClangARMNeon ClangAttrClasses ClangAttrList
+ ClangDiagnosticSema ClangDeclNodes ClangStmtNodes
+ ClangAttrTemplateInstantiate ClangAttrParsedAttrList
+ ClangAttrParsedAttrKinds)
+
+