summaryrefslogtreecommitdiff
path: root/clang/lib/Sema/CMakeLists.txt
diff options
context:
space:
mode:
authorCarlo Zancanaro <carlo@pc-4w14-0.cs.usyd.edu.au>2012-10-15 17:10:06 +1100
committerCarlo Zancanaro <carlo@pc-4w14-0.cs.usyd.edu.au>2012-10-15 17:10:06 +1100
commitbe1de4be954c80875ad4108e0a33e8e131b2f2c0 (patch)
tree1fbbecf276bf7c7bdcbb4dd446099d6d90eaa516 /clang/lib/Sema/CMakeLists.txt
parentc4626a62754862d20b41e8a46a3574264ea80e6d (diff)
parentf1bd2e48c5324d3f7cda4090c87f8a5b6f463ce2 (diff)
Merge branch 'master' of ssh://bitbucket.org/czan/honours
Diffstat (limited to 'clang/lib/Sema/CMakeLists.txt')
-rw-r--r--clang/lib/Sema/CMakeLists.txt58
1 files changed, 58 insertions, 0 deletions
diff --git a/clang/lib/Sema/CMakeLists.txt b/clang/lib/Sema/CMakeLists.txt
new file mode 100644
index 0000000..07734c7
--- /dev/null
+++ b/clang/lib/Sema/CMakeLists.txt
@@ -0,0 +1,58 @@
+set(LLVM_USED_LIBS
+ clangAST
+ clangAnalysis
+ clangBasic
+ clangEdit
+ clangLex
+ )
+
+add_clang_library(clangSema
+ AnalysisBasedWarnings.cpp
+ AttributeList.cpp
+ CodeCompleteConsumer.cpp
+ DeclSpec.cpp
+ DelayedDiagnostic.cpp
+ IdentifierResolver.cpp
+ JumpDiagnostics.cpp
+ Scope.cpp
+ Sema.cpp
+ SemaAccess.cpp
+ SemaAttr.cpp
+ SemaCXXScopeSpec.cpp
+ SemaCast.cpp
+ SemaChecking.cpp
+ SemaCodeComplete.cpp
+ SemaConsumer.cpp
+ SemaDecl.cpp
+ SemaDeclAttr.cpp
+ SemaDeclCXX.cpp
+ SemaDeclObjC.cpp
+ SemaExceptionSpec.cpp
+ SemaExpr.cpp
+ SemaExprCXX.cpp
+ SemaExprMember.cpp
+ SemaExprObjC.cpp
+ SemaFixItUtils.cpp
+ SemaInit.cpp
+ SemaLambda.cpp
+ SemaLookup.cpp
+ SemaObjCProperty.cpp
+ SemaOverload.cpp
+ SemaPseudoObject.cpp
+ SemaStmt.cpp
+ SemaStmtAttr.cpp
+ SemaTemplate.cpp
+ SemaTemplateDeduction.cpp
+ SemaTemplateInstantiate.cpp
+ SemaTemplateInstantiateDecl.cpp
+ SemaTemplateVariadic.cpp
+ SemaType.cpp
+ TargetAttributesSema.cpp
+ )
+
+add_dependencies(clangSema ClangARMNeon ClangAttrClasses ClangAttrList
+ ClangDiagnosticSema ClangDeclNodes ClangStmtNodes
+ ClangAttrTemplateInstantiate ClangAttrParsedAttrList
+ ClangAttrParsedAttrKinds)
+
+