summaryrefslogtreecommitdiff
path: root/lemon/demo/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lemon/demo/Makefile.am')
-rw-r--r--lemon/demo/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/lemon/demo/Makefile.am b/lemon/demo/Makefile.am
new file mode 100644
index 0000000..800cd01
--- /dev/null
+++ b/lemon/demo/Makefile.am
@@ -0,0 +1,17 @@
+AM_CXXFLAGS = $(WARNINGCXXFLAGS)
+
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_builddir)
+LDADD = $(top_builddir)/lemon/libemon.la
+
+EXTRA_DIST = \
+ CMakeLists.txt \
+ digraph.lgf
+
+noinst_PROGRAMS = \
+ arg_parser_demo \
+ graph_to_eps_demo \
+ lgf_demo
+
+arg_parser_demo_SOURCES = arg_parser_demo.cc
+graph_to_eps_demo_SOURCES = graph_to_eps_demo.cc
+lgf_demo_SOURCES = lgf_demo.cc