summaryrefslogtreecommitdiff
path: root/lemon/demo/Makefile.am
diff options
context:
space:
mode:
authorCarlo Zancanaro <carlo@pc-4w14-0.cs.usyd.edu.au>2012-07-10 13:44:21 +1000
committerCarlo Zancanaro <carlo@pc-4w14-0.cs.usyd.edu.au>2012-07-10 13:44:21 +1000
commitef4a319984d22b88a9024ff523700d657621124d (patch)
tree2821db78ccd6ce61ca64ad6fc98ba825b060ca6a /lemon/demo/Makefile.am
parentd3f13fdd23e17a8f4bb4083c24fee331a28351eb (diff)
Add the LEMON graph library source to the repo
I'll likely be using it, so this just makes it easier to get to from elsewhere. If I end up not using it then I can just delete it.
Diffstat (limited to 'lemon/demo/Makefile.am')
-rw-r--r--lemon/demo/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/lemon/demo/Makefile.am b/lemon/demo/Makefile.am
new file mode 100644
index 0000000..800cd01
--- /dev/null
+++ b/lemon/demo/Makefile.am
@@ -0,0 +1,17 @@
+AM_CXXFLAGS = $(WARNINGCXXFLAGS)
+
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_builddir)
+LDADD = $(top_builddir)/lemon/libemon.la
+
+EXTRA_DIST = \
+ CMakeLists.txt \
+ digraph.lgf
+
+noinst_PROGRAMS = \
+ arg_parser_demo \
+ graph_to_eps_demo \
+ lgf_demo
+
+arg_parser_demo_SOURCES = arg_parser_demo.cc
+graph_to_eps_demo_SOURCES = graph_to_eps_demo.cc
+lgf_demo_SOURCES = lgf_demo.cc