summaryrefslogtreecommitdiff
path: root/lemon/demo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lemon/demo/CMakeLists.txt')
-rw-r--r--lemon/demo/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/lemon/demo/CMakeLists.txt b/lemon/demo/CMakeLists.txt
new file mode 100644
index 0000000..e0566f4
--- /dev/null
+++ b/lemon/demo/CMakeLists.txt
@@ -0,0 +1,19 @@
+INCLUDE_DIRECTORIES(
+ ${PROJECT_SOURCE_DIR}
+ ${PROJECT_BINARY_DIR}
+)
+
+LINK_DIRECTORIES(
+ ${PROJECT_BINARY_DIR}/lemon
+)
+
+SET(DEMOS
+ arg_parser_demo
+ graph_to_eps_demo
+ lgf_demo
+)
+
+FOREACH(DEMO_NAME ${DEMOS})
+ ADD_EXECUTABLE(${DEMO_NAME} ${DEMO_NAME}.cc)
+ TARGET_LINK_LIBRARIES(${DEMO_NAME} lemon)
+ENDFOREACH()