summaryrefslogtreecommitdiff
path: root/clang/runtime/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'clang/runtime/CMakeLists.txt')
-rw-r--r--clang/runtime/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/clang/runtime/CMakeLists.txt b/clang/runtime/CMakeLists.txt
new file mode 100644
index 0000000..68ee266
--- /dev/null
+++ b/clang/runtime/CMakeLists.txt
@@ -0,0 +1,12 @@
+# TODO: Set the install directory.
+
+set(known_subdirs
+ "compiler-rt"
+ "libcxx"
+ )
+
+foreach (dir ${known_subdirs})
+ if (EXISTS ${CMAKE_CURRENT_SOURCE_DIR}/${dir}/CMakeLists.txt)
+ add_subdirectory(${CMAKE_CURRENT_SOURCE_DIR}/${dir})
+ endif()
+endforeach()