summaryrefslogtreecommitdiff
path: root/clang/lib/AST/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'clang/lib/AST/CMakeLists.txt')
-rw-r--r--clang/lib/AST/CMakeLists.txt57
1 files changed, 57 insertions, 0 deletions
diff --git a/clang/lib/AST/CMakeLists.txt b/clang/lib/AST/CMakeLists.txt
new file mode 100644
index 0000000..716459a
--- /dev/null
+++ b/clang/lib/AST/CMakeLists.txt
@@ -0,0 +1,57 @@
+set(LLVM_LINK_COMPONENTS support)
+
+set(LLVM_USED_LIBS clangBasic clangLex)
+
+add_clang_library(clangAST
+ APValue.cpp
+ ASTConsumer.cpp
+ ASTContext.cpp
+ ASTDiagnostic.cpp
+ ASTImporter.cpp
+ AttrImpl.cpp
+ CXXInheritance.cpp
+ Decl.cpp
+ DeclarationName.cpp
+ DeclBase.cpp
+ DeclCXX.cpp
+ DeclFriend.cpp
+ DeclGroup.cpp
+ DeclObjC.cpp
+ DeclPrinter.cpp
+ DeclTemplate.cpp
+ DumpXML.cpp
+ Expr.cpp
+ ExprClassification.cpp
+ ExprConstant.cpp
+ ExprCXX.cpp
+ ExternalASTSource.cpp
+ InheritViz.cpp
+ ItaniumCXXABI.cpp
+ ItaniumMangle.cpp
+ LambdaMangleContext.cpp
+ Mangle.cpp
+ MicrosoftCXXABI.cpp
+ MicrosoftMangle.cpp
+ NestedNameSpecifier.cpp
+ NSAPI.cpp
+ ParentMap.cpp
+ RecordLayout.cpp
+ RecordLayoutBuilder.cpp
+ SelectorLocationsKind.cpp
+ Stmt.cpp
+ StmtDumper.cpp
+ StmtIterator.cpp
+ StmtPrinter.cpp
+ StmtProfile.cpp
+ StmtViz.cpp
+ TemplateBase.cpp
+ TemplateName.cpp
+ Type.cpp
+ TypeLoc.cpp
+ TypePrinter.cpp
+ VTableBuilder.cpp
+ VTTBuilder.cpp
+ )
+
+add_dependencies(clangAST ClangARMNeon ClangAttrClasses ClangAttrList
+ ClangAttrImpl ClangDiagnosticAST ClangDeclNodes ClangStmtNodes)