summaryrefslogtreecommitdiff
path: root/clang/lib/ARCMigrate/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'clang/lib/ARCMigrate/CMakeLists.txt')
-rw-r--r--clang/lib/ARCMigrate/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/clang/lib/ARCMigrate/CMakeLists.txt b/clang/lib/ARCMigrate/CMakeLists.txt
new file mode 100644
index 0000000..fcb7f72
--- /dev/null
+++ b/clang/lib/ARCMigrate/CMakeLists.txt
@@ -0,0 +1,29 @@
+set(LLVM_USED_LIBS clangBasic clangAST clangParse clangFrontend clangRewrite)
+
+add_clang_library(clangARCMigrate
+ ARCMT.cpp
+ ARCMTActions.cpp
+ FileRemapper.cpp
+ ObjCMT.cpp
+ PlistReporter.cpp
+ TransAPIUses.cpp
+ TransARCAssign.cpp
+ TransAutoreleasePool.cpp
+ TransBlockObjCVariable.cpp
+ TransEmptyStatementsAndDealloc.cpp
+ TransformActions.cpp
+ Transforms.cpp
+ TransGCAttrs.cpp
+ TransGCCalls.cpp
+ TransProperties.cpp
+ TransRetainReleaseDealloc.cpp
+ TransUnbridgedCasts.cpp
+ TransUnusedInitDelegate.cpp
+ TransZeroOutPropsInDealloc.cpp
+ )
+
+add_dependencies(clangARCMigrate
+ ClangAttrClasses
+ ClangAttrList
+ ClangDeclNodes
+ ClangStmtNodes)