summaryrefslogtreecommitdiff
path: root/clang/examples/analyzer-plugin/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'clang/examples/analyzer-plugin/CMakeLists.txt')
-rw-r--r--clang/examples/analyzer-plugin/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/clang/examples/analyzer-plugin/CMakeLists.txt b/clang/examples/analyzer-plugin/CMakeLists.txt
new file mode 100644
index 0000000..2b9d825
--- /dev/null
+++ b/clang/examples/analyzer-plugin/CMakeLists.txt
@@ -0,0 +1,14 @@
+set(MODULE TRUE)
+
+set( LLVM_USED_LIBS
+ clangStaticAnalyzerCore
+ )
+
+set( LLVM_LINK_COMPONENTS support mc)
+
+add_clang_library(SampleAnalyzerPlugin MainCallChecker.cpp)
+
+set_target_properties(SampleAnalyzerPlugin
+ PROPERTIES
+ LINKER_LANGUAGE CXX
+ PREFIX "")