summaryrefslogtreecommitdiff
path: root/lemon/Makefile.am
diff options
context:
space:
mode:
authorCarlo Zancanaro <carlo@pc-4w14-0.cs.usyd.edu.au>2012-07-10 13:44:21 +1000
committerCarlo Zancanaro <carlo@pc-4w14-0.cs.usyd.edu.au>2012-07-10 13:44:21 +1000
commitef4a319984d22b88a9024ff523700d657621124d (patch)
tree2821db78ccd6ce61ca64ad6fc98ba825b060ca6a /lemon/Makefile.am
parentd3f13fdd23e17a8f4bb4083c24fee331a28351eb (diff)
Add the LEMON graph library source to the repo
I'll likely be using it, so this just makes it easier to get to from elsewhere. If I end up not using it then I can just delete it.
Diffstat (limited to 'lemon/Makefile.am')
-rw-r--r--lemon/Makefile.am80
1 files changed, 80 insertions, 0 deletions
diff --git a/lemon/Makefile.am b/lemon/Makefile.am
new file mode 100644
index 0000000..9c86f2a
--- /dev/null
+++ b/lemon/Makefile.am
@@ -0,0 +1,80 @@
+ACLOCAL_AMFLAGS = -I m4
+
+AM_CXXFLAGS = $(WARNINGCXXFLAGS)
+
+AM_CPPFLAGS = -I$(top_srcdir) -I$(top_builddir)
+LDADD = $(top_builddir)/lemon/libemon.la
+
+EXTRA_DIST = \
+ AUTHORS \
+ LICENSE \
+ m4/lx_check_cplex.m4 \
+ m4/lx_check_glpk.m4 \
+ m4/lx_check_soplex.m4 \
+ m4/lx_check_coin.m4 \
+ CMakeLists.txt \
+ cmake/FindGhostscript.cmake \
+ cmake/FindCPLEX.cmake \
+ cmake/FindGLPK.cmake \
+ cmake/FindCOIN.cmake \
+ cmake/LEMONConfig.cmake.in \
+ cmake/version.cmake.in \
+ cmake/version.cmake \
+ cmake/nsis/lemon.ico \
+ cmake/nsis/uninstall.ico
+
+pkgconfigdir = $(libdir)/pkgconfig
+lemondir = $(pkgincludedir)
+bitsdir = $(lemondir)/bits
+conceptdir = $(lemondir)/concepts
+pkgconfig_DATA =
+lib_LTLIBRARIES =
+lemon_HEADERS =
+bits_HEADERS =
+concept_HEADERS =
+noinst_HEADERS =
+noinst_PROGRAMS =
+bin_PROGRAMS =
+check_PROGRAMS =
+dist_bin_SCRIPTS =
+TESTS =
+XFAIL_TESTS =
+
+include lemon/Makefile.am
+include test/Makefile.am
+include doc/Makefile.am
+include tools/Makefile.am
+include scripts/Makefile.am
+
+DIST_SUBDIRS = demo
+
+demo:
+ $(MAKE) $(AM_MAKEFLAGS) -C demo
+
+MRPROPERFILES = \
+ aclocal.m4 \
+ config.h.in \
+ config.h.in~ \
+ configure \
+ Makefile.in \
+ build-aux/config.guess \
+ build-aux/config.sub \
+ build-aux/depcomp \
+ build-aux/install-sh \
+ build-aux/ltmain.sh \
+ build-aux/missing \
+ doc/doxygen.log
+
+mrproper:
+ $(MAKE) $(AM_MAKEFLAGS) maintainer-clean
+ -rm -f $(MRPROPERFILES)
+
+dist-bz2: dist
+ zcat $(PACKAGE)-$(VERSION).tar.gz | \
+ bzip2 --best -c > $(PACKAGE)-$(VERSION).tar.bz2
+
+distcheck-bz2: distcheck
+ zcat $(PACKAGE)-$(VERSION).tar.gz | \
+ bzip2 --best -c > $(PACKAGE)-$(VERSION).tar.bz2
+
+.PHONY: demo mrproper dist-bz2 distcheck-bz2