summaryrefslogtreecommitdiff
path: root/clang/tools/c-index-test/CMakeLists.txt
diff options
context:
space:
mode:
authorZancanaro; Carlo <czan8762@plang3.cs.usyd.edu.au>2012-09-24 09:58:17 +1000
committerZancanaro; Carlo <czan8762@plang3.cs.usyd.edu.au>2012-09-24 09:58:17 +1000
commit222e2a7620e6520ffaf4fc4e69d79c18da31542e (patch)
tree7bfbc05bfa3b41c8f9d2e56d53a0bc3e310df239 /clang/tools/c-index-test/CMakeLists.txt
parent3d206f03985b50beacae843d880bccdc91a9f424 (diff)
Add the clang library to the repo (with some of my changes, too).
Diffstat (limited to 'clang/tools/c-index-test/CMakeLists.txt')
-rw-r--r--clang/tools/c-index-test/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/clang/tools/c-index-test/CMakeLists.txt b/clang/tools/c-index-test/CMakeLists.txt
new file mode 100644
index 0000000..c44b34b
--- /dev/null
+++ b/clang/tools/c-index-test/CMakeLists.txt
@@ -0,0 +1,16 @@
+set(LLVM_USED_LIBS libclang)
+
+set( LLVM_LINK_COMPONENTS
+ support
+ mc
+ )
+
+add_clang_executable(c-index-test
+ c-index-test.c
+ )
+
+set_target_properties(c-index-test
+ PROPERTIES
+ LINKER_LANGUAGE CXX)
+
+install(TARGETS c-index-test RUNTIME DESTINATION bin)