summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 22 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..6357f28
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,22 @@
+from setuptools import setup
+
+setup(
+ name='SnakeGame',
+ version='1.0',
+ description='The game of Snake, for beginner AI bot writers.',
+ author='Peter Ward',
+ author_email='peteraward@gmail.com',
+ packages=['snakegame'],
+ zip_safe=False,
+ install_requires=[
+ 'six',
+ ],
+ package_data={
+ 'snakegame': 'images/*.png',
+ },
+ entry_points={
+ 'console_scripts': [
+ 'snakegame = snakegame:main',
+ ]
+ },
+)