summaryrefslogtreecommitdiff
path: root/clang/lib/Lex/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'clang/lib/Lex/CMakeLists.txt')
-rw-r--r--clang/lib/Lex/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/clang/lib/Lex/CMakeLists.txt b/clang/lib/Lex/CMakeLists.txt
new file mode 100644
index 0000000..0a2ffdb
--- /dev/null
+++ b/clang/lib/Lex/CMakeLists.txt
@@ -0,0 +1,31 @@
+# TODO: Add -maltivec when ARCH is PowerPC.
+
+set(LLVM_LINK_COMPONENTS support)
+
+set(LLVM_USED_LIBS clangBasic)
+
+add_clang_library(clangLex
+ HeaderMap.cpp
+ HeaderSearch.cpp
+ Lexer.cpp
+ LiteralSupport.cpp
+ MacroArgs.cpp
+ MacroInfo.cpp
+ ModuleMap.cpp
+ PPCaching.cpp
+ PPCallbacks.cpp
+ PPDirectives.cpp
+ PPExpressions.cpp
+ PPLexerChange.cpp
+ PPMacroExpansion.cpp
+ PTHLexer.cpp
+ Pragma.cpp
+ PreprocessingRecord.cpp
+ Preprocessor.cpp
+ PreprocessorLexer.cpp
+ ScratchBuffer.cpp
+ TokenConcatenation.cpp
+ TokenLexer.cpp
+ )
+
+add_dependencies(clangLex ClangDiagnosticLex ClangAttrSpellings)